Важная информация

User Tag List

Страница 1 из 2 12 ПоследняяПоследняя
Показано с 1 по 10 из 19

Тема: Pentagon 128k debugging

  1. #1
    Member Аватар для Shockwav3
    Регистрация
    09.09.2008
    Адрес
    Berlin, Germany
    Сообщений
    38
    Благодарностей: 1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию Pentagon 128k debugging

    Hi there,
    I'm currently in the progress of building a Pentagon 128 (Revision 2011 produced by zorel). Good things first, it already boots, accepts keyboard input and even lists betadisk directories. Now comes the bad part, after a few seconds I get junk characters on the screen, but the machine remains operational for a few more seconds til it crashes (mostly after 30-45 seconds). Sometimes it reboots, but most of the time it just hangs requiring a hard reset. Any ideas what could be wrong?

    Further info:
    - IC type is all 74lsxxx except for dd02, dd11 & dd12 (used 74hct93 there). I used the translation table from here: http://sblive.narod.ru/ZX-Spectrum/P...ntagon128k.htm (except for dd100 which is wrong there and should be cd4069).
    - RAM chips are 41256 and have decoupling capacitors
    - random decoupling capacitors have been placed on the board
    - resistor and capacitor values have been used according to pentagon.pdf from here http://zxspectrum.it.omegahg.com/doc/Pentagon.pdf

    Here's also a picture:
    http://img855.imageshack.us/img855/9...ntagon128k.jpg

    So any ideas what to try next?
    - ZX Spectrum +2+ MP3 to Tape Adapter + Scart Cable
    - Pentagon 1024SL V2.2 + Z-Controller + NeoGS + TSFM + 2x 3.5" & 1x 5.25" Floppy + 2GB CF-Card + Tape-In
    Pentagon 128 Revision 2011 + AY-Daughterboard + ZX-Kit 1
    ---
    Sorry, I don't speak Russian / К сожалению, я не говорю по-русски

  2. #1
    С любовью к вам, Yandex.Direct
    Размещение рекламы на форуме способствует его дальнейшему развитию

  3. #2
    Guru Аватар для null_device
    Регистрация
    26.09.2009
    Адрес
    г. Красноярск
    Сообщений
    2,679
    Благодарностей: 2035
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Are all the errors of the board have been eliminated?

    http://zx.pk.ru/showpost.php?p=535392&postcount=371

    Is the board AY \ YM, it also is an error.
    Последний раз редактировалось null_device; 10.02.2013 в 01:42.
    Когда есть, но не знаеш где - это все равно, что нету.

  4. #3
    Member Аватар для Shockwav3
    Регистрация
    09.09.2008
    Адрес
    Berlin, Germany
    Сообщений
    38
    Благодарностей: 1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Thanks for letting me know about that one - didn't know about that one before, fixed that, didn't help much
    I've also fixed the missing track on dd31 and added R50 (56kohm)
    - ZX Spectrum +2+ MP3 to Tape Adapter + Scart Cable
    - Pentagon 1024SL V2.2 + Z-Controller + NeoGS + TSFM + 2x 3.5" & 1x 5.25" Floppy + 2GB CF-Card + Tape-In
    Pentagon 128 Revision 2011 + AY-Daughterboard + ZX-Kit 1
    ---
    Sorry, I don't speak Russian / К сожалению, я не говорю по-русски

  5. #4
    Guru Аватар для null_device
    Регистрация
    26.09.2009
    Адрес
    г. Красноярск
    Сообщений
    2,679
    Благодарностей: 2035
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Sorry if this mу advice does not help.
    In the next branch, discussed the assembly and adjustment of the board, try to ask a question there.

    http://zx.pk.ru/showpost.php?p=574471&postcount=983
    Когда есть, но не знаеш где - это все равно, что нету.

  6. #5
    Member Аватар для Shockwav3
    Регистрация
    09.09.2008
    Адрес
    Berlin, Germany
    Сообщений
    38
    Благодарностей: 1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Just to let you guys know: both of my Pentagons are up and running
    Appears the first one was suffering from a flakey PSU (I was using my PC's) and C7 being soldered in the wrong place and the second one must have had a cold solderjoint, as it magically started working once I re-soldered every chip.

    So ... what are good measures for testing that everything is working alright?
    I've tried loading and running a demo from disk (Alienate by Hooy-Program), loading and saving a program from/to tape, testing the INT and RAM using Test 4.30 (which also confirms the tact at 171680 cycles).
    One more thing that comes to my mind would be testing a demo that uses covox sound and that would be pretty much all.
    - ZX Spectrum +2+ MP3 to Tape Adapter + Scart Cable
    - Pentagon 1024SL V2.2 + Z-Controller + NeoGS + TSFM + 2x 3.5" & 1x 5.25" Floppy + 2GB CF-Card + Tape-In
    Pentagon 128 Revision 2011 + AY-Daughterboard + ZX-Kit 1
    ---
    Sorry, I don't speak Russian / К сожалению, я не говорю по-русски

  7. #6
    Guru
    Регистрация
    16.12.2009
    Адрес
    Харьков
    Сообщений
    3,605
    Благодарностей: 1752
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Цитата Сообщение от Shockwav3 Посмотреть сообщение
    testing the INT and RAM using Test 4.30 (which also confirms the tact at 171680 cycles).
    How many INT cycles? "Too short", "Too long" or..?

    One more thing that comes to my mind would be testing a demo that uses covox sound and that would be pretty much all.
    If you connect DAC (R-2R or 8bit chip) on "printer port"... only after that you can hear covox sound.
    Profi must live!

    Моё железо...

    1. Profi 5.06/1Mb(DRAM)+Profi5.06(UP)/HDD/3`5FDD/CF512Mb/SD-CARD
    2. Profi 3.2/1Mb/3`5FDD/HDD6.4Gb/Pentagon_Fix
    3. Profi 6.2 Rev. B/1Mb/3`5FDD/HDD3.2Gb
    4. Profi 5.05(down)/1Mb+Profi 5.03(UP)/Pentagon_Fix
    Все укомплектованы:
    Profi_ZX-BUS/ZXMC2/NemoIDE/SounDrive
    [свернуть]

  8. #7
    Member Аватар для Shockwav3
    Регистрация
    09.09.2008
    Адрес
    Berlin, Germany
    Сообщений
    38
    Благодарностей: 1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Test 4.30 gives me 32-28
    TestInt reports 40-36
    Hidden part of the Insult Megademo shows just fine.
    - ZX Spectrum +2+ MP3 to Tape Adapter + Scart Cable
    - Pentagon 1024SL V2.2 + Z-Controller + NeoGS + TSFM + 2x 3.5" & 1x 5.25" Floppy + 2GB CF-Card + Tape-In
    Pentagon 128 Revision 2011 + AY-Daughterboard + ZX-Kit 1
    ---
    Sorry, I don't speak Russian / К сожалению, я не говорю по-русски

  9. #8
    Guru
    Регистрация
    16.12.2009
    Адрес
    Харьков
    Сообщений
    3,605
    Благодарностей: 1752
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Цитата Сообщение от Shockwav3 Посмотреть сообщение
    Test 4.30 gives me 32-28
    TestInt reports 40-36
    Hidden part of the Insult Megademo shows just fine.
    there are no more questions) pentagon work properly. my congratulations!!!
    Profi must live!

    Моё железо...

    1. Profi 5.06/1Mb(DRAM)+Profi5.06(UP)/HDD/3`5FDD/CF512Mb/SD-CARD
    2. Profi 3.2/1Mb/3`5FDD/HDD6.4Gb/Pentagon_Fix
    3. Profi 6.2 Rev. B/1Mb/3`5FDD/HDD3.2Gb
    4. Profi 5.05(down)/1Mb+Profi 5.03(UP)/Pentagon_Fix
    Все укомплектованы:
    Profi_ZX-BUS/ZXMC2/NemoIDE/SounDrive
    [свернуть]

  10. #9
    Veteran Аватар для ZXMAK
    Регистрация
    30.01.2006
    Адрес
    Харьков
    Сообщений
    1,288
    Благодарностей: 749
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Цитата Сообщение от solegstar Посмотреть сообщение
    there are no more questions) pentagon work properly. my congratulations!!!
    он жаловался на то что все работает, выводит каталог диска, но через несколько секунд появляются случайные символы и затем через 30 сек крешится..
    ZXMAK2 - Виртуальная Машина ZX Spectrum http://zxmak2.codeplex.com
    ZXMAK.NET - спектрум на C# http://sourceforge.net/projects/zxmak-dotnet

  11. #10
    Guru
    Регистрация
    16.12.2009
    Адрес
    Харьков
    Сообщений
    3,605
    Благодарностей: 1752
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Цитата Сообщение от Alexander Makeev Посмотреть сообщение
    он жаловался на то что все работает, выводит каталог диска, но через несколько секунд появляются случайные символы и затем через 30 сек крешится..
    где? этот баг кажись устранен давно. он вроде отписался, что всё работает замечательно и он погонял разные тесты, демы и т.д....
    Profi must live!

    Моё железо...

    1. Profi 5.06/1Mb(DRAM)+Profi5.06(UP)/HDD/3`5FDD/CF512Mb/SD-CARD
    2. Profi 3.2/1Mb/3`5FDD/HDD6.4Gb/Pentagon_Fix
    3. Profi 6.2 Rev. B/1Mb/3`5FDD/HDD3.2Gb
    4. Profi 5.05(down)/1Mb+Profi 5.03(UP)/Pentagon_Fix
    Все укомплектованы:
    Profi_ZX-BUS/ZXMC2/NemoIDE/SounDrive
    [свернуть]

Страница 1 из 2 12 ПоследняяПоследняя

Информация о теме

Пользователи, просматривающие эту тему

Эту тему просматривают: 1 (пользователей: 0 , гостей: 1)

Похожие темы

  1. куплю pentagon 128k
    от ZX1997 в разделе Барахолка (архив)
    Ответов: 6
    Последнее: 12.01.2012, 13:41
  2. Как быть с реалом - Pentagon 128k ?
    от dM_GBG в разделе Pentagon
    Ответов: 42
    Последнее: 24.05.2011, 02:37
  3. Помогите с Pentagon-128k !
    от r0m в разделе Pentagon
    Ответов: 383
    Последнее: 15.05.2010, 00:51
  4. Ответов: 57
    Последнее: 03.04.2010, 06:42
  5. Ответов: 0
    Последнее: 24.01.2010, 21:46

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •