Важная информация

User Tag List

Страница 32 из 33 ПерваяПервая ... 282930313233 ПоследняяПоследняя
Показано с 311 по 320 из 325

Тема: Тестер микросхем на ATMega16/32

  1. #311
    Member
    Регистрация
    11.04.2017
    Адрес
    г. Нижний Новгород
    Сообщений
    76
    Благодарностей: 11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Цитата Сообщение от creator Посмотреть сообщение
    Сейчас посмотрел внимательно на схему... вот я дебил... А я как-то наивно полагал что все ключи одинаковые и положением перемычки выбирается будет блок ключей плюсовой или минусовой. Тогда как-то вообще не вижу в этих перемычках смысла.
    Я тоже наступил на эти же грабли - запаял везде 2502))

  2. #312
    Member
    Регистрация
    12.04.2016
    Адрес
    г. Санкт-Петербург
    Сообщений
    39
    Благодарностей: 9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Цитата Сообщение от Trol73 Посмотреть сообщение
    Звук точно работает с 817. Вообще, схема правильная - на пищалке должен быть NPN, на дисплее - PNP. Но я ошибочно поставил NPN на дисплей, и прошивку делал для такого включения (оба транзистора NPN). И оно оказалось работоспособным. Хоть и не правильным.
    Так какие все-таки транзисторы ставить, на шелкографии печатной платы указаны оба 817?

  3. #313

  4. Этот пользователь поблагодарил Trol73 за это полезное сообщение:
    ShokoD (23.01.2018)

  5. #314
    Member
    Регистрация
    12.04.2016
    Адрес
    г. Санкт-Петербург
    Сообщений
    39
    Благодарностей: 9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Собрал дисплей 128х128 (на замену Nokia 5110), прошил основную и дисплейную платы, работать не хочет на экране надпись (c) TrolSoft, на кнопки не реагирует. Что бы это могло быть?

  6. #315
    Activist Аватар для Trol73
    Регистрация
    07.05.2015
    Адрес
    г. Ульяновск
    Сообщений
    273
    Благодарностей: 309
    Записей в дневнике
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Там на экране ещё должна очень быстро бежать полоска, есть такое? Rx одной платы подключен на Tx другой? Контакт есть? Фьюзы верные?

  7. #316
    Member
    Регистрация
    12.04.2016
    Адрес
    г. Санкт-Петербург
    Сообщений
    39
    Благодарностей: 9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Цитата Сообщение от Trol73 Посмотреть сообщение
    Там на экране ещё должна очень быстро бежать полоска, есть такое? Rx одной платы подключен на Tx другой? Контакт есть? Фьюзы верные?
    Полоска есть вверху, Rx и Tx правильно, контакт есть, фьюзы выставлял как у вас на сайте. Прошивки брал в ВК для 128х128 дисплейный модуль Версия 0.8.7 (97), основная плата Версия 0.8.10 (100), микропроцессор ATmega328P.

  8. #316
    С любовью к вам, Yandex.Direct
    Размещение рекламы на форуме способствует его дальнейшему развитию

  9. #317
    Activist Аватар для Trol73
    Регистрация
    07.05.2015
    Адрес
    г. Ульяновск
    Сообщений
    273
    Благодарностей: 309
    Записей в дневнике
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Тогда надо смотреть (осциллографом, логическим анализатором или хотя бы вольтметром) состояние выводов Tx тестера. Есть ли там какие импульсы? Т.е., для начала надо убедиться, что основная плата пытается что-то передать на дисплейную. Если импульсы есть, то посмотреть состояние вывода Tx дисплея (пытается ли он что-то ответить).

    Если фьюзы верные, то полоска вверху будет очень быстро бежать. Если нет (включён режим деления частоты на 8, он установлен по умолчанию), то полоска будет бежать медленно.
    Если всё точно сделано правильно, то остаётся только вариант убитого UART-а на стороне m328p, но это совсем маловероятно..

  10. #318
    Member
    Регистрация
    12.04.2016
    Адрес
    г. Санкт-Петербург
    Сообщений
    39
    Благодарностей: 9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Полоска бежит, на мой взгляд быстро, осциллограф допотопный, что-то им ничего не вижу. Вольтметр показывает на Tx тестера 0,02 В, на Tx дисплея почти 5 В, если отсоединить UART и оставить питание на дисплейной плате, то эти напряжения остаются на дисплее, т. е. Rx=0.02V, Tx=4.95V, а на обоих выводах Rx и Tx платы тестера 0.

  11. #319
    Activist Аватар для Trol73
    Регистрация
    07.05.2015
    Адрес
    г. Ульяновск
    Сообщений
    273
    Благодарностей: 309
    Записей в дневнике
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Вообще, по моему опыту, примитивным китайским мультиметром можно определить наличие импульсов UART-а. Если не видите их на Tx тестера, то можно вернуть дисплейный модуль 5110, прошить тестер под него и проверить наличие импульсов, которые там гарантировано будут. На всякий случай, потом можно попробовать ещё другие прошивки для цветного дисплея.

  12. #320
    Member
    Регистрация
    12.04.2016
    Адрес
    г. Санкт-Петербург
    Сообщений
    39
    Благодарностей: 9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Вернул модуль 5110, перепрошил тестер, импульсы на осциллографе вижу, тестер тоже показывает около 4 В на Rx и Tx, чудеса какие-то.

Страница 32 из 33 ПерваяПервая ... 282930313233 ПоследняяПоследняя

Информация о теме

Пользователи, просматривающие эту тему

Эту тему просматривают: 1 (пользователей: 0 , гостей: 1)

Похожие темы

  1. Ответов: 16
    Последнее: 28.09.2014, 08:43
  2. AY + тестер = нужна помощь!
    от Black_Cat в разделе Unsorted
    Ответов: 3
    Последнее: 16.07.2011, 20:17
  3. ТЕСТЕР микросхем логики
    от Mikka_A в разделе Unsorted
    Ответов: 29
    Последнее: 19.03.2007, 22:46
  4. Ответов: 22
    Последнее: 28.01.2007, 12:20

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •