PDA

Просмотр полной версии : zx-spectrum+ 128k видеосигнал



HitPo
06.01.2011, 23:26
воскрешаю из мертвых любимый компьютер. пациент из англии, фирменный. симптом - нет видеосигнала, все остальное по всей видимости теперь работает (многое не работало :)). теа2000 исправна, покупалась новая - ничего не изменилось. кабель из синклер шопа, ргб, соответственно исправный. на экране видны темные тени меню, еле различается, все остальное черное. в какую сторону копать?

RST 0
07.01.2011, 06:11
HitPo, а есть ли возможность сделать фото?

HitPo
07.01.2011, 10:52
HitPo, а есть ли возможность сделать фото?

конечно, фото с меню получилось даже как-то нормально, на самом деле оно практически не видно.

RST 0
07.01.2011, 15:11
Может быть телевизор не правильно отображает? Изображение вроде как в негативе,возможно нужно его проинвертировать?

BYTEMAN
07.01.2011, 15:30
http://members.multimania.co.uk/eightbitula/zx128/zx128a.png

По этой схеме я бы проверил TR14 и катушку L6

---------- Post added at 14:30 ---------- Previous post was at 14:30 ----------

Ну и ещё L5

---------- Post added at 14:30 ---------- Previous post was at 14:30 ----------

На обрыв

doorsfan
08.01.2011, 03:23
ничего не ломай. померяй напряжение на 16 ноге скарта. 99.9%, что оно ниже нормы.

---------- Post added at 02:23 ---------- Previous post was at 02:21 ----------

в амстрадных клонах стоит идиотский 1КОм на +12 на видеовыходе. вероятно, в вашем синклере тоже. уменьшайте до 650 Ом и будет вам цветное счастье.

BYTEMAN
08.01.2011, 03:26
doorsfan, дык, как я понял, по композиту подключаются? или tea2000 RGB-видеосигнал на выходе даёт?

---------- Post added at 02:26 ---------- Previous post was at 02:24 ----------


в амстрадных клонах стоит идиотский 1КОм на +12 на видеовыходе. вероятно, в вашем синклере тоже. уменьшайте до 650 Ом и будет вам цветное счастье.
Если по РГБ подключаются, тогда очень похоже на правду, т.к. если на мой телевизор подать чистую синхру, то изображение тоже очень похожее (только без вертикальных линий).

doorsfan
08.01.2011, 03:32
секундочку. в вашем синкляре не выводится напряжение переключения телевизора в скарт-ргб. в +2 (переразведенный клон) я отказался от вывода на разъём вертикальной синхронизации и композитного бесполезного (галимого) видеосигнала, чтобы подать через, если не изменяет память, 270-омный резистор +9 - +12 (с БП) (на 1ю ногу DIN-8, чтобы совпасть с распайкой +3, чтобы не убить зомбопанель при перепутывании шнурков) и звук (на 5ю ногу, хотя в +3 эта нога соединена с 1й, но в шнурке от +3 эта нога не используется мною) на скарт. в самом скарте эти +9 подайте на 8 ногу, а с неё через ещё около 370 Ом на 16ю. И не берите +12 с преобразователя: он слабомощный, дополнительную нагрузку не вытягивает, ничего хорошего не получится.
а вообще поиск по форуму рулит, в который раз даю ссылку на это сообщение: http://zx.pk.ru/showpost.php?p=287660&postcount=10

HitPo
08.01.2011, 17:12
секундочку. в вашем синкляре не выводится напряжение переключения телевизора в скарт-ргб. в +2 (переразведенный клон) я отказался от вывода на разъём вертикальной синхронизации и композитного бесполезного (галимого) видеосигнала, чтобы подать через, если не изменяет память, 270-омный резистор +9 - +12 (с БП) (на 1ю ногу DIN-8, чтобы совпасть с распайкой +3, чтобы не убить зомбопанель при перепутывании шнурков) и звук (на 5ю ногу, хотя в +3 эта нога соединена с 1й, но в шнурке от +3 эта нога не используется мною) на скарт. в самом скарте эти +9 подайте на 8 ногу, а с неё через ещё около 370 Ом на 16ю. И не берите +12 с преобразователя: он слабомощный, дополнительную нагрузку не вытягивает, ничего хорошего не получится.
а вообще поиск по форуму рулит, в который раз даю ссылку на это сообщение: http://zx.pk.ru/showpost.php?p=287660&postcount=10


этот пдф я уже изучал. вобщем подключаю к обычному толстому телевизору, композит отсутствует как сигнал, после экспериментов выяснилось что ргб сигналы тоже отсутсвуют. тени на экране - это показатель сигнала BRIGHT, похоже только он доходит до разъема. теа2000 повторюсь - исправна. по поводу резисторов - внутри скарта уже собрана схема доработки, т.к. кабель заказывался из англии уже заточенным именно под 128к спектрум.

doorsfan
08.01.2011, 20:37
осциллограф есть? слова подтверждены отсутствием импульсов на всех выходах, кроме синхры и брайта? на ТЕА забейте, ведь Вы подключаетесь как синхро+РГБ. Ещё раз, сколько вольт на 16 ноге скарта?
Телек не станет включать входы РГБ, если на ней не будет 1,5-3 Вольта. Соответственно картинка будет такая никакая, как Вы описали.
да, "фирменность" шнура не означает его соответствие стандарту СКАРТ. Т.е. не означает, что всё будет работать так, как Вы хотите. Ну Вы ж поняли, что шнур не цепляется к краевому разъёму, поэтому в нём никак не образуется нужное постоянное напряжение для 16й ноги.

sevol
09.01.2011, 19:02
Так нужно проверять кондеры, о собенно питание - типа проблема может быть из-за заниженого напряжения в цепи(у этих спеков постоянные проблемы с ним) и транзисторы. И пропаять микрухи. Такое читал на испанском форуме про спеки. Они там по ходу только так их и ремонтируют.

---------- Post added at 17:43 ---------- Previous post was at 17:40 ----------

вот тут почитай, про синхру я думаю что-то найдешь http://www.speccy.org/foro/viewforum.php?f=8

---------- Post added at 18:01 ---------- Previous post was at 17:43 ----------

http://www.worldofspectrum.org/forums/showthread.php?t=28944

---------- Post added at 18:02 ---------- Previous post was at 18:01 ----------

http://www.secarica.ro/html/plus3_hardware.html#compositevideo

HitPo
16.01.2011, 23:23
осциллограф есть? слова подтверждены отсутствием импульсов на всех выходах, кроме синхры и брайта? на ТЕА забейте, ведь Вы подключаетесь как синхро+РГБ. Ещё раз, сколько вольт на 16 ноге скарта?
Телек не станет включать входы РГБ, если на ней не будет 1,5-3 Вольта. Соответственно картинка будет такая никакая, как Вы описали.
да, "фирменность" шнура не означает его соответствие стандарту СКАРТ. Т.е. не означает, что всё будет работать так, как Вы хотите. Ну Вы ж поняли, что шнур не цепляется к краевому разъёму, поэтому в нём никак не образуется нужное постоянное напряжение для 16й ноги.

ок, я проверил, там +0.7в. чтож, напряжения я так понимаю недостаточно? что конкретно можете посоветовать сделать (кроме замены кондеров)? ранее совет был дан применительно к +3?

вкратце расскажу его историю. попал этот последний шедевр сэра Синклера ко мне полным трупом, только тело, без бп. после замены сгоревшей как оказалось кренки на UA7805C (кстати, достаточно ли её, или нужна мощнее?). тело сразу потеплело, и начало подавать признаки жизни. попытки подключения через композит ничего не дали, сигнала не было. при распайке ргб я увидел только выше указанную картинку с тенями, что вобщем-то воодушевило, т.к. комп все же работал. помимо кренки, сгоревшей оказалась и клавиатура, чьи пленочные контакты были все обугленные и сгоревшие. также беспокоило отсутствие звука. была заказана новая пленка для клавы, теа2000 и ргб шнур с аудиоджеком. теперь теа2000 стоит новая, клава новая, звук вроде появился :). осталась проблема с изображением.

фотка платы.

BYTEMAN
17.01.2011, 00:00
HitPo, есть осциллограф? Надо было бы проконтролировать сигналы на контактах 37, 38, 39 и 42 ULAшки. Если нет осцилла, то хотя бы подать сигнал с этих контактов на композитный видеовход телевизора. Должно быть очень-очень яркое изображение менюшки (без синхроницации, всё будет дрожать - дёргаться).

HitPo
17.01.2011, 02:44
осцилографа нет. блин, послушался... подал на телек с 37 ноги юлы - теперь отображается полосатый серый матрац, никакой яркой картинки. меню пропало. похоже что-то я подпалил.

BYTEMAN
17.01.2011, 03:36
HitPo, я надеюсь, минуса были соединены надёжно?????

---------- Post added at 02:36 ---------- Previous post was at 01:58 ----------

37-й контакт - это сигнал BLUE. Так что всё правильно. Либо где-то соплю повесили, либо минус отвалился, а это уже очень плохо.

HitPo
17.01.2011, 15:45
ну вопщем похоже он сдох окончательно. имхо юла отдала концы. придется отсылать в квалифицированный ремонт

Atari
17.01.2011, 15:54
землю видеокабеля проверять пробовали?