Важная информация

User Tag List

Страница 1 из 3 123 ПоследняяПоследняя
Показано с 1 по 10 из 29

Тема: ATM Turbo 2+ ver 7.15 - нужна помощь с наладкой, проблемы с изображением

  1. #1
    Member
    Регистрация
    05.08.2019
    Адрес
    г. Нижний Новгород
    Сообщений
    46
    Спасибо Благодарностей отдано 
    14
    Спасибо Благодарностей получено 
    38
    Поблагодарили
    3 сообщений
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию ATM Turbo 2+ ver 7.15 - нужна помощь с наладкой, проблемы с изображением

    Друзья, приветствую!
    Очень нужна помощь по наладке моей недавно собранной платки АТМ-Турбо2+ вер. 7.15.
    В общем, имеется вот что: компьютер в целом стартует, но:
    1) Только после ресета, неважно тестовая ПЗУ или БИОС;
    2) При запуске тестовой ПЗУ-шки ( Тест памяти ATM-turbo 2+ от Чунина Романа (2004 год) ) - картинка как на видео (т.е. неправильные цвета на полосах, причём, после каждого ресета разные, иногда, очень редко, бывают верные цветовые полосы), и по изображению идёт как-бы шум в виде горизонтальных чёрточек, выстроенных в вертикальные линии:

    Скрытый текст


    3) При запуске с ПЗУ BIOS отображается экран как на видео, не видно курсора и надписей на окошке выбора сверху и снизу и по изображению идёт тот же самый шум как и в п. 2:

    Скрытый текст


    4) Тест памяти показывает вот такую картинку:

    Скрытый текст



    [свернуть]


    Очень жду любой помощи! Просто крик души, помогите наладить АТМ-ку, уже извёлся весь!

    Да, забыл сказать, блокировочные конденсаторы 1мкф напаял, на всю память и по всей плате ~ через 1 микросхему (кое-где даже и на каждую). Стало с шумом получше, но всё равно полностью не ушёл. Питание от блока питания АТХ Cougar VTE X2 650, нового.
    Последний раз редактировалось mdaemon; 24.05.2022 в 23:41.
    ZX Tape Reviver - программа для графического восстановления повреждённых аудио-кассет

  2. #1
    С любовью к вам, Yandex.Direct
    Размещение рекламы на форуме способствует его дальнейшему развитию

  3. #2
    Member
    Регистрация
    10.09.2021
    Адрес
    г. Харьков, Украина
    Сообщений
    32
    Спасибо Благодарностей отдано 
    1
    Спасибо Благодарностей получено 
    11
    Поблагодарили
    8 сообщений
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    1) Только после ресета, неважно тестовая ПЗУ или БИОС;
    Это стандартная проблема, связаная со стартом разных участков схемы АТМ вразнобой. На 100% решается любым супервизором сброса на линию +5В (у меня стоит PST529D). Как альтернативу в теории можно попробовать повесить конденсатор большой ёмкости между землёй и RES/, но я не пробовал.

    картинка как на видео (т.е. неправильные цвета на полосах, причём, после каждого ресета разные, иногда, очень редко, бывают верные цветовые полосы)
    Так память же глючит. Надо с этим сначала разобраться. А вообще смотреть формирователь изображения, на схеме 7.10 в верхнем правом углу (D46-D48, D96, D11 и что ещё с ними связано).

  4. Этот пользователь поблагодарил Zugzug за это полезное сообщение:

    mdaemon (25.05.2022)

  5. #3
    Member
    Регистрация
    05.08.2019
    Адрес
    г. Нижний Новгород
    Сообщений
    46
    Спасибо Благодарностей отдано 
    14
    Спасибо Благодарностей получено 
    38
    Поблагодарили
    3 сообщений
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Zugzug, я запускал ещё тест "Тест памяти ATM-turbo 2+ и ATM-turbo 3 от MSD888 (New!!!)" - говорит, что с видеопамятью всё ОК, более того, я вот, читая мануал, нашёл, что за цвета отвечают D53, D54 - пробовал ставить другие, в том числе, пробовал менять РУ2 на РУ9 - результат одинаковый, т.е. не помогло.
    Микросхемы (те, которые возможно) перед установкой проверял тестом, который есть в программаторе TL866-II Plus. Показывало ОК.
    Кстати, попутно вопрос по памяти, точнее по результату работы теста: я так понимаю, что 512КБ заканчиваются на 31 банке памяти. Почему тогда за пределами этого объёма тест иногда показывает "+"?
    И по поводу п.3. - у меня подозрение, что цвета у рамки при запуске с ПЗУ БИОС неверные. К сожалению, в то время, в 90х, когда у меня была АТМ-ка, я пользовался ч/б монитором, поэтому, не знаю, какие должны быть цвета. Но косвенно судя по отсутствию курсора и надписей - это так.
    ZX Tape Reviver - программа для графического восстановления повреждённых аудио-кассет

  6. #4
    Member
    Регистрация
    17.07.2018
    Адрес
    г. Воронеж
    Сообщений
    187
    Спасибо Благодарностей отдано 
    4
    Спасибо Благодарностей получено 
    24
    Поблагодарили
    23 сообщений
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Не стартующий сам АТМ это норма, конденсатор не RESET помогает, но с ним у меня уже не стартовала Zxnetusb, пришлось о паять.
    Неверные цвета тоже нормальное явление, там это особенность теста и прерываний.

    - - - Updated - - -

    Да 512 КБ это 32 банка, тест там довольно незамысловато тестирует, так чо иногда вероятно умудряется найти фантомную память.
    Судя по тому что тесты успешно работают, Прошивка стартует и шевелится, то память и ее дешифрация работает нормально. А Мусор вылезает где-то уже на пути из ОЗУ на экран. Так, а дальше-то можно провалиться в TR-DOS или CP/M?

  7. Этот пользователь поблагодарил Kulich за это полезное сообщение:

    mdaemon (25.05.2022)

  8. #5
    Member
    Регистрация
    05.08.2019
    Адрес
    г. Нижний Новгород
    Сообщений
    46
    Спасибо Благодарностей отдано 
    14
    Спасибо Благодарностей получено 
    38
    Поблагодарили
    3 сообщений
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Kulich, я ещё не подключал клавиатуру, подключу - отпишусь! Но в тестах, где Спектрумовский экран и 320х200 всё показывает чисто (замыкал пинцетом соотв. контакты для прохождения теста). Я тоже подозреваю, что в целом всё как-то шевелится, но вот с изображением уже весь мозг себе сломал: проверял микросхемы тестером - говорит рабочие. Тыкал осциллографом - в целом, на мой непросвещённый взгляд, похоже на то, что нарисовано в мануале. И куда копать - уже не знаю. Те микросхемы, на которые были подозрения - я заменил. Результата нет. Потому и взываю к помощи знающих людей!
    И вопрос по начальной менюшке в БИОСе открытый - почему не видно курсора и текста? Кстати, нашёл цветное фото с менюшкой - цвета-таки неверные на рамке:

    Скрытый текст



    [свернуть]


    Update:
    Сравнивая изображение, которое у меня, и которое на фото, понял, что проблема в цветах. Т.е. у меня рамка рисуется с белым цветом фона (и тень от рамки голубая, а на фото - зелёная), а должна быть коричневой, соответственно, потому и не виден курсор и буквы - они тоже белым цветом. Вот и получается, что белый на белом не видно. Соответственно, ещё один вопрос: кто может быть виноват за то, что палитра сформировалась неверно?
    Последний раз редактировалось mdaemon; 25.05.2022 в 17:05.
    ZX Tape Reviver - программа для графического восстановления повреждённых аудио-кассет

  9. #6
    Member
    Регистрация
    10.09.2021
    Адрес
    г. Харьков, Украина
    Сообщений
    32
    Спасибо Благодарностей отдано 
    1
    Спасибо Благодарностей получено 
    11
    Поблагодарили
    8 сообщений
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Цитата Сообщение от mdaemon Посмотреть сообщение
    Но в тестах, где Спектрумовский экран и 320х200 всё показывает чисто
    Понимаю что сильно не помогу, но если спектрум работает без шума, то как минимум регистры D47-D48 + D42 нормальные. Если глючит текстовый режим, то поломаны какие-то сигналы приходящие на ПЗУшку. Маловероятно что поломан регистр D41. Возможно надо смотреть V0-V2 приходящие с D8 или ZOE/ c D64. Ещё хорошо бы перепроверить нормальная ли HL8 (или ГАЛка).

    Кстати прохождение теста в программаторе это необходимое, но не достаточное условие работы м/c. У меня была дивно глючащая ТМ2, которая проверку проходила, но при работе в схеме выдавала удивительное.

    Тестовая ПЗУшка по идее должна выдавать not memory на все отсутствующие страницы, по крайней мере у меня так было. Что пишет тест MSD888 не знаю.

  10. #7
    Member
    Регистрация
    05.08.2019
    Адрес
    г. Нижний Новгород
    Сообщений
    46
    Спасибо Благодарностей отдано 
    14
    Спасибо Благодарностей получено 
    38
    Поблагодарили
    3 сообщений
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Zugzug, за любой ответ - спасибо! Никогда не знаешь, что натолкнёт на решение проблемы ) . Насколько я понимаю, почитав мануал, текстовый и графический режимы не очень отличаются (за исключением, что идёт выборка символов из ПЗУ), но в данном случае глючат оба режима. ХЛ8 я пробовал менять, разницы нету, вычитывал программатором - всё совпадает с эталонной прошивкой. Сейчас попробую подключить клавиатуру и выйти в какой-нибудь пункт из меню БИОС. Кстати, попутно вопрос - какие верные положения джамперов на плате, может я что-то не так выставил?

    - - - Добавлено - - -

    Цитата Сообщение от Kulich Посмотреть сообщение
    Не стартующий сам АТМ это норма, конденсатор не RESET помогает, но с ним у меня уже не стартовала Zxnetusb, пришлось о паять.
    Неверные цвета тоже нормальное явление, там это особенность теста и прерываний.

    - - - Updated - - -

    А Мусор вылезает где-то уже на пути из ОЗУ на экран. Так, а дальше-то можно провалиться в TR-DOS или CP/M?
    Попробовал запустить СР/М и выйти в спектрум - заходит в пункты меню как положено. Единственное, после установки ВЕ31 и ПЗУ с прошивкой шум усилился ещё сильнее:

    Скрытый текст


    В ТР-ДОС не выходит, т.к. ВГ93 не установлен.
    Последний раз редактировалось mdaemon; 25.05.2022 в 20:18.
    ZX Tape Reviver - программа для графического восстановления повреждённых аудио-кассет

  11. #8
    Member
    Регистрация
    17.07.2018
    Адрес
    г. Воронеж
    Сообщений
    187
    Спасибо Благодарностей отдано 
    4
    Спасибо Благодарностей получено 
    24
    Поблагодарили
    23 сообщений
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Так, глючит только 80 колонтчный режим? Так, там есть парочка счётчиков пикселей для знакомест и в расширенных режимах они немного по другому считают. Думаю если открыть инструкцию по наладке атм2+ и почитать отличия в работе режимов ответ сам пр дет в голову.
    Ну и вокруг ПЗУ знакогенератора потанцевать, неконтат, глюк, сопля, непропай, или просто не вывозит.

  12. #9
    Member
    Регистрация
    05.08.2019
    Адрес
    г. Нижний Новгород
    Сообщений
    46
    Спасибо Благодарностей отдано 
    14
    Спасибо Благодарностей получено 
    38
    Поблагодарили
    3 сообщений
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Цитата Сообщение от Kulich Посмотреть сообщение
    Так, глючит только 80 колонтчный режим? Так, там есть парочка счётчиков пикселей для знакомест и в расширенных режимах они немного по другому считают. Думаю если открыть инструкцию по наладке атм2+ и почитать отличия в работе режимов ответ сам пр дет в голову.
    Ну и вокруг ПЗУ знакогенератора потанцевать, неконтат, глюк, сопля, непропай, или просто не вывозит.
    Kulich, да, всё верно, именно высокое разрешение глючит. Я смотрел эти м/сх, что по мануалу указаны. Пойду ещё раз смотреть, попробую поменять их что-ли. Ну и мануал покурю. ПЗУ точно рабочее, стоит сейчас РФ5, пробовал 2716, у которой время выборки меньше, но разницы не было. Точно такая же микросхема ПЗУ (РФ5) стоит на контроллере клавиатуры, клавиатура работает стабильно.
    ZX Tape Reviver - программа для графического восстановления повреждённых аудио-кассет

  13. #10
    Member
    Регистрация
    10.09.2021
    Адрес
    г. Харьков, Украина
    Сообщений
    32
    Спасибо Благодарностей отдано 
    1
    Спасибо Благодарностей получено 
    11
    Поблагодарили
    8 сообщений
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    По умолчанию

    Цитата Сообщение от mdaemon Посмотреть сообщение
    Единственное, после установки ВЕ31 и ПЗУ с прошивкой шум усилился ещё сильнее
    Я бы потратил вечер и напаял блокировочные конденсаторы на каждую м/c просто чтобы исключить фактор помех по питанию. Всё равно может получиться быстрее чем ловить глюки от помех. Меня в своё время IDE контроллер несколько дней изводил чтением мусора. Прозванивал соединения, микросхемы менял, а потом напаял одну ёмкость и всё заработало.

Страница 1 из 3 123 ПоследняяПоследняя

Информация о теме

Пользователи, просматривающие эту тему

Эту тему просматривают: 1 (пользователей: 0 , гостей: 1)

Похожие темы

  1. Ответов: 18
    Последнее: 26.03.2019, 13:26
  2. Ответов: 7
    Последнее: 18.05.2018, 20:48
  3. Atm-Turbo 2+ (ver.7.10)
    от stakh в разделе ATM
    Ответов: 16
    Последнее: 20.06.2011, 19:57
  4. ATM Turbo-2+ ver 7.00/ Глюки
    от Hakuna в разделе ATM
    Ответов: 10
    Последнее: 08.02.2010, 12:20
  5. ATM Turbo 2 (плата ver 6.15)
    от rasmer в разделе ATM
    Ответов: 6
    Последнее: 27.01.2007, 11:47

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •